0

I just installed Elementary on my Lenovo S21e. Looks really good but my touchpad and wifi are not working. hope this can be solved.

greets, Maarten

  • 1
    Did the touchpad work during elementary OS installation? – Vlad Pop May 2 '17 at 23:41
1

Are you able to connect it to the internet somehow? I'm reading the specs and I see this model does not have an Ethernet port. If you can somehow (USB tethering from phone?) get online on it, run in Terminal:

sudo apt update && sudo apt upgrade && sudo apt dist-upgrade

and then

sudo apt install broadcom-sta-common broadcom-sta-dkms broadcom-sta-source

Reboot.

1

First enter sudo apt-get update && sudo apt-get upgrade

Watch the video in the link below it worked on my laptop, I too had that touchpad problem press ctrl+alt+t for opening the terminal and do what as suggested in the video and restart the system the touch pad works.

https://m.youtube.com/watch?v=ZAPSrbZvsjk

Hope it works!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.