I have a new Carbon X1 and as a first step I try to install the wifi-driver. I checked arch and it says I need iwlwifi


i googled it and found


but first step doesn't work.

Can you give a brief summary to install the driver?

Regards snowparrot

  • Please edit the question to include results from terminal for lspci -nnk | grep -iA3 net; uname -r as there isn't a way to give a good answer without that info. The iwlwifi module is included in the kernel and most of the firmware is installed by default but there are a few new Intel wifi devices that don't have support in the 4.4 kernel
    – Jeremy31
    May 5, 2017 at 21:46
  • I just install the new Ubuntu hardware stack. It solved all problems!
    – snowparrot
    May 6, 2017 at 21:54

3 Answers 3


Used my iPhone to get a temporary Internet connection, and found this site: http://www.edimax.com/edimax/download/download/data/edimax/global/download/for_home/wireless_adapters/wireless_adapters_ac1750_dual-band/ew-7833uac

Used the Linux drivers for my ASUS 1900 AC68 USB device and worked on the first try. Before I updated the driver, I performed all of the OS updates through my iPhone, just in case that makes a difference.


Under elementary OS, to get iwlwifi working, you only have to install the linux-firmware and the linux-image-extra-virtual packages.


I would just go to Software & Updates and look under Additional Drivers. If you have a proprietary wifi driver, it will most likely be listed here. This is probably the most stable way to do it.

Otherwise you can try these answers, since EOS is based on Ubuntu:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.