After a recent update (end of last week) my Pantheon-Terminal has now a weird behavior: When I open it, it is very shortly transparent but immediately gets opaque after that (maybe not even half a second later). Before, the terminal just stayed transparent, like one would expect.

I'm actually not sure if the update was an update of pantheon-terminal - but I think that there was no update for it, so probably some update for some other component of pantheon is responsible for that.

Does anybody else has this problem too?

  • You might want to reset terminal (transparency) properties under gsettings, it might work again.
    – lemonslice
    May 2, 2017 at 18:36
  • You mean the alpha channel of the RGBA background property? This I tried already. Transparency works, but only for a few seconds unfortunately... Before the update it worked perfectly. May 2, 2017 at 19:01
  • If it is not enough try to reset all terminal settings and/or use the guest account to isolate the issue.
    – lemonslice
    May 3, 2017 at 5:58
  • It is indeed true - for the guest account, the transparency works. The weird thing is, resetting the terminal settings does not help. All settings are now identical to the ones in the guest account, but transparency still disappears... Any ideas where else I could look? Maybe gsettings somewhere else than org.pantheon.terminal? May 3, 2017 at 16:47
  • Having the same issue, did you ever find an answer?
    – amallard
    May 29, 2017 at 8:53

2 Answers 2


You can edit the transparency level in Elementary Tweaks. Give that a shot, see if it sticks.

  • I did that already before. And it also works. The problem is, that the transparency disappears after half a second... Before the update it stayed and worked perfectly. May 2, 2017 at 18:58

I'm new here but this doesn't sound like any kind of purposeful feature on the part of the developers to me. I'd report an issue on the Github repository, including as much scathing detail as you possibly can about what's happening and how you got here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.