1

tldr; How can I disable search as you type in files.

Hi, I navigate within folders using keyboard and when I type doc it should focus on documents folder but instead it opens recursive search and shows some doc file in some child folder. How can I disable this behaviour?

1

There isn't a way of doing this - other than installing an older version of Files.

This behaviour (i.e. only one search mode) was introduce at r2445 following bug report https://bugs.launchpad.net/pantheon-files/+bug/1604300.

However, only the first part of the intended changes have been released; the second part is still awaiting review. The second part will fix the sorting of the search results such that the first result, selected by default, will be the same as what you would have got with the old search by typing (current folder only, starting with search term).

Hopefully this will remove any need to be able to disable the new behaviour (it is unlikely any such new options/settings would be accepted into elementaryos).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.