0

Title says it all. I installed some updates yesterday (hadn't updated in around ~6 months) to my Freya (don't laugh) system. Today, whenever I enter my password and press enter, a black screen flashes, and I get sent back to the login screen.

If I enter a terminal and run cat ~/.xsession-errors, I get:

Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
gnome-session[4898]: WARNING: Error while executing session-migration: Failed to execute child process "session-migration" (No such file or directory)
gnome-session[4898]: WARNING: Could not parse desktop file remmina-applet.desktop or it references a not found TryExec binary
gnome-session[4898]: WARNING: Could not parse desktop file nylas-mail.desktop or it references a not found TryExec binary
gnome-session[4898]: WARNING: Could not parse desktop file user-dirs-update-gtk-pantheon.desktop or it references a not found TryExec binary
gnome-session[4898]: WARNING: Could not parse desktop file parcellite-startup.desktop or it references a not found TryExec binary
gnome-session[4898]: WARNING: Could not parse desktop file user-dirs-update-gtk.desktop or it references a not found TryExec binary
gnome-session[4898]: WARNING: Could not parse desktop file clipit-startup.desktop or it references a not found TryExec binary

(gnome-settings-daemon:5043): media-keys-plugin-WARNING **: Grab failed for some keys, another application may already have access the them.

(gala:5096): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed
gnome-session[4898]: WARNING: Application 'gala.desktop' killed by signal 11

(gala:5115): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed
gnome-session[4898]: WARNING: Application 'gala.desktop' killed by signal 11
gnome-session[4898]: WARNING: App 'gala.desktop' respawning too quickly
gnome-session[4898]: CRITICAL: We failed, but the fail whale is dead. Sorry....

(gnome-settings-daemon:5043): Gdk-WARNING **: gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

I have no clue what's going on Help!!

0

Well, that was easier than I thought...

I just did Ctrl+F1 -> logged in -> sudo chown ryan:ryan .Xauthority.

  • mark your question to solved if you managed to fix that – Egon Stetmann. Jun 16 '17 at 22:19
0

This is a known bug in dbus.

Workaround:

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.backup

More info: https://bugs.launchpad.net/elementaryos/+bug/1596377 or https://mail.gnome.org/archives/commits-list/2016-July/msg02793.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.