0

Sometimes, after a few hours of use, elementary freezes and I have to shut it down by hold the power button. This is happening to me since I upgraded from Freya (didn't happen) to Loki.

My laptop is Asus-X550

  • Intel i5-3337U
  • Nvidia Geforce 720m
  • 8 GB of RAM

Normally, when it freezes I have Chrome a bunch of tabs opened in Chrome and Intellij IDEA opened, a few hours have passed and I try to open other program, heavy or not. Maybe I need more RAM? But I think that 8 GB is enough to handle that...

I have also Windows 10 installed and no problems on it, so we can discard a hardware problem

Any suggestions?


UPDATE:

Okay, so I reinstalled Loki and happened again:

https://pastebin.com/5eYH0Yky

The /var/log/syslog file after the system logged out itself (after waiting 3 or 4 minutes waiting without control of the mouse nor keyboard and without effect pressing Ctrl+Alt+F1) and logged in again.

Before starting to freeze, I launched Eclipse and only one tab in Chrome was opened at the same time.

Also, I had the top command running and there was nothing strange at the beginning of freezing, java (Eclipse) was taking about 0,7 % of RAM and was the most RAM consuming process. But after waiting those 3 minutes the XOrg service began to take more and more RAM, taking all of it until it logged out (Which is an outrage thing, given that I have 8 GB of RAM and was being used just before freezing about 2% of it)

Anyone know what is happening and how could I fix it?

  • Check the following link : unix.stackexchange.com/questions/38608/… and try to upload the logs. :) – Martin Spasov Apr 17 '17 at 7:30
  • Updated! I installed Loki again but it still happens. Seems like a Xorg server problem. Please, can you take a look again? – jacosro Apr 17 '17 at 19:00
  • I don't really have the knowledge to help out, I am new eOS user too. Told you to get the logs so that the other people on the forum won't have to and will have them ready :) – Martin Spasov Apr 17 '17 at 20:25
1

Hello and welcome to the large family of Optimus-enabled-elementary-powered-laptop users, I too own a slightly similar model (Asus K53SD, i3-2350M, nVidia GeForce 610M, 6GB RAM) and had it happily spew Xorg errors and kernel panics for a long time. The laptop ran very hot all the time, even idle, and the battery drained at an alarming rate. The general idea was that both graphic cards were active, and they were both trying to access the same resources.

The solution was to upgrade the kernel and install the appropriate nVidia driver from the Ubuntu drivers PPA. BUT the thing is, not any combination will work, for me it was a trial-and-error process: upgrade to a certain kernel, install an nVidia driver from the ppa, check functionality, fail, purge driver, install next one, and so on. It took a while, but got lucky and managed to find a very stable combination:

  • Kernel 4.8.0-040800rc6-generic
  • nvidia-370

I know the kernel is a Release Candidate, but it's the only one that worked for me, the machine behaves exemplary, and frankly I've been quite reluctant to try another upgrade, for it might break everything. So these are my steps, proceed with care:

  1. Kernel upgrade:

    mkdir upgrade

    cd upgrade

    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8-rc6/linux-headers-4.8.0-040800rc6_4.8.0-040800rc6.201609121119_all.deb

    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8-rc6/linux-headers-4.8.0-040800rc6-generic_4.8.0-040800rc6.201609121119_amd64.deb

    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8-rc6/linux-image-4.8.0-040800rc6-generic_4.8.0-040800rc6.201609121119_amd64.deb

    sudo dpkg -i *.deb

    sudo reboot

  2. Add Ubuntu drivers repository:

    sudo add-apt-repository ppa:graphics-drivers/ppa

    sudo apt update

  3. Install nVidia driver:

    sudo apt install nvidia-370 nvidia-settings nvidia-prime

    sudo reboot

    At this point, there's a 50% chance you might end up with a black screen. If this is the case, open a tty console (Ctrl + Alt + F1 in the black screen), login with your user and password, and:

    sudo apt purge nvidia*

    sudo reboot

Now you should have a functional nVidia driver. From the Applications menu run NVIDIA X Server Settings, select PRIME Profiles and make sure Intel (Power Saving Mode) is selected. If not, select it and relog.
If the black screen after reboot happens, you just have to try a newer driver from the ppa (replace nvidia-370 in the command above with something else: nvidia-375, nvidia-378). Ultimately, you might have to try a different kernel.
PRIME Profiles will allow you to manually switch between graphics cards, as needed. Using Intel will increase battery duration and keep your laptop cool, using nVidia will make games run better.

  • Thank you for your effort helping me. When I upgraded to Loki and tried to install nvidia drivers I got black screen like 5 different times. As result, I had to reinstall everything and set up again my computer. Now, I don't have time to do this and I need the computer for my job, so I will stay as I am. Maybe one day I'll try this. Certainly, elementary is sooo buggy... – jacosro Apr 22 '17 at 0:56
  • This is not an elementary issue per se, but more of an nVidia one, mainly driver compatibility. Even the official drivers from nvidia.com often require quite a hefty amount of tinkering (disable Secure Boot, stop LightDM before installing, blacklisting stuff...) to make them work. I have the same issue with another laptop (Acer E15, i5-6200U, GeForce 940MX) where cards switch only after a reboot. – Pop Vlad Apr 22 '17 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.