0

I am using Loki on my Lenovo X1 Yoga. Very recently an update has enabled the accelerometer, so the screen automatically rotates with the laptop. However, there are two big problems:

  1. The orientation of the screen is wrong. I don't know how to either disable it, or to correct it. Running xrandr --output eDP1 --rotate normal temporarily restores the correct orientation, but moving the laptop results in the incorrect orientation.

  2. The accelerometer detection only does anything once the laptop has been to sleep, and has resumed. Upon first booting, my system works fine without the rotation.

Any ideas how to deal with this would be much appreciated.

  • I have the same problem with my Dell Inspiron 3000 2in1 – Brian Haythorn Jul 27 '17 at 22:13
1

Same problem here.

xrandr -o 0

has helped temporarily. The problem, actually lies in FIXING this. Obviously, the system somehow detects the orientation AND reacts on it. It only so happens that the detected orientation is wrong. Now, where does it happen? That's what we need to fix. Thanks a lot :)

0

Run the following command and test -

xrandr -o 0

You can test with 0,1,2,3 and see which one gives correct output.

Then add the command to your startup.

0

Try to set orientation lock in dconf settings:

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true

This should block screen orientation in the user session, but I'm not sure about Greeter (Pantheon's LightDM Login Screen).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.