1

When a try:

sudo apt install elementary-sdk

it says

Unable to locate package elementary-sdk

It's a fresh install of loki.

apt update 

give me a 404 error.

Err:7 http://br.archive.ubuntu.com/ubuntu loki Release                                                                                                 
404  Not Found [IP: 200.236.31.4 80]
1

This is a repository error: there is no Ubuntu version "loki", you should use "xenial" Ubuntu repositories with elementary repositories.

/etc/apt/sources.list.d/elementary.list:

deb http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial main
deb-src http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial main

/etc/apt/sources.list.d/patches.list:

deb http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial main
deb-src http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial main
| improve this answer | |
  • I will investigate later tonight, but seems to me that software-properties-common is messing around with sources list. – williangnr Apr 13 '17 at 15:41
0

I can verify updating "hera" to "bionic" in the following source list files allowed me to install elementary-sdk just now (for Elementary OS 5.1):

/etc/apt/sources.list
/etc/apt/sources.list.d/elementary.list
/etc/apt/sources.list.d/patches.list
/etc/apt/sources.list.d/appcenter.list

This appears to be an ongoing issue the past 4 years so I've filed a bug in GitHub so this gets fixed at its root.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.