0

so first. I've installed Android Studio and its working fine, except when I try to create AVD virtual device it says:

An error occurred while creating the AVD. See idea.log for details.

i found a solution to use sudo apt-get install lib32stdc++6 at first it did not work it brought out

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it

so i decided to search for a solution and i found a few soultions from here Unable to lock the administration directory (/var/lib/dpkg/) is another process using it? - Ask Ubuntu So i tried the command again to fix my android studio

sudo apt-get install lib32stdc++6

then it brought out:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 lib32stdc++6 : Depends: lib32gcc1 (>= 1:4.2) but it is not going to be installed
                Depends: libc6-i386 (>= 2.18) but it is not going to be installed
 libobasis5.3-calc : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                     Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-en-us-base : Depends: libobasis5.3-en-us (>= 5.3.1.2) but it is not installable
                           Depends: libobasis5.3-en-us (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-en-us-calc : Depends: libobasis5.3-en-us (>= 5.3.1.2) but it is not installable
                           Depends: libobasis5.3-en-us (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-en-us-math : Depends: libobasis5.3-en-us (>= 5.3.1.2) but it is not installable
                           Depends: libobasis5.3-en-us (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-en-us-res : Depends: libobasis5.3-en-us (>= 5.3.1.2) but it is not installable
                          Depends: libobasis5.3-en-us (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-extension-javascript-script-provider : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                                                     Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-extension-mediawiki-publisher : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                                              Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-filter-data : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                            Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-gnome-integration : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                                  Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-graphicfilter : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                              Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-images : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                       Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-kde-integration : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                                Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-librelogo : Depends: libobasis5.3-writer (>= 5.3.1.2) but it is not installable
                          Depends: libobasis5.3-writer (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-ogltrans : Depends: libobasis5.3-impress (>= 5.3.1.2) but it is not installable
                         Depends: libobasis5.3-impress (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-ooofonts : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                         Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-pyuno : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                      Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libobasis5.3-xsltfilter : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                           Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
 libreoffice5.3-base : Depends: libreoffice5.3 (>= 5.3.1.2) but it is not installable
                       Depends: libreoffice5.3 (<= 5.3.1.2-2) but it is not installable
                       Depends: libobasis5.3-base (>= 5.3.1.2) but it is not installable
                       Depends: libobasis5.3-base (<= 5.3.1.2-2) but it is not installable
 libreoffice5.3-calc : Depends: libreoffice5.3 (>= 5.3.1.2) but it is not installable
                       Depends: libreoffice5.3 (<= 5.3.1.2-2) but it is not installable
 libreoffice5.3-dict-es : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                          Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
                          Depends: libreoffice5.3 (>= 5.3.1.2) but it is not installable
                          Depends: libreoffice5.3 (<= 5.3.1.2-2) but it is not installable
 libreoffice5.3-dict-fr : Depends: libobasis5.3-core (>= 5.3.1.2) but it is not installable
                          Depends: libobasis5.3-core (<= 5.3.1.2-2) but it is not installable
                          Depends: libreoffice5.3 (>= 5.3.1.2) but it is not installable
                          Depends: libreoffice5.3 (<= 5.3.1.2-2) but it is not installable
 libreoffice5.3-en-us : Depends: libreoffice5.3 (>= 5.3.1.2) but it is not installable
                        Depends: libreoffice5.3 (<= 5.3.1.2-2) but it is not installable
                        Depends: libobasis5.3-en-us (>= 5.3.1.2) but it is not installable
                        Depends: libobasis5.3-en-us (<= 5.3.1.2-2) but it is not installable
                        Depends: libobasis5.3-en-us-writer (>= 5.3.1.2) but it is not installable
                        Depends: libobasis5.3-en-us-writer (<= 5.3.1.2-2) but it is not installable
 libreoffice5.3-impress : Depends: libreoffice5.3 (>= 5.3.1.2) but it is not installable
                          Depends: libreoffice5.3 (<= 5.3.1.2-2) but it is not installable
                          Depends: libobasis5.3-impress (>= 5.3.1.2) but it is not installable
                          Depends: libobasis5.3-impress (<= 5.3.1.2-2) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried my android studio AVD again and it still brought out the same error. I tried the command a recommended by the terminal

apt-get -f install

and got:

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

switched to root and tried it again and got:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gir1.2-javascriptcoregtk-4.0 gir1.2-json-1.0 gir1.2-soup-2.4 gir1.2-webkit2-4.0 libido3-0.1-0
  switchboard-plug-gcc-bluetooth
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  libobasis5.3-calc libobasis5.3-en-us-base libobasis5.3-en-us-calc libobasis5.3-en-us-math
  libobasis5.3-en-us-res libobasis5.3-extension-javascript-script-provider
  libobasis5.3-extension-mediawiki-publisher libobasis5.3-filter-data libobasis5.3-gnome-integration
  libobasis5.3-graphicfilter libobasis5.3-images libobasis5.3-kde-integration libobasis5.3-librelogo
  libobasis5.3-ogltrans libobasis5.3-ooofonts libobasis5.3-pyuno libobasis5.3-xsltfilter
  libreoffice5.3-base libreoffice5.3-calc libreoffice5.3-dict-es libreoffice5.3-dict-fr
  libreoffice5.3-en-us libreoffice5.3-impress
0 upgraded, 0 newly installed, 23 to remove and 102 not upgraded.
23 not fully installed or removed.
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/

tried over and over again. but no progress. I don't know what to do right now!

0

You still have some dpkg, apt or similar process running. You have to kill them first (or do simply a reboot).

If even this does not help you might have to remove the lockfile manually: sudo rm /var/cache/apt/archives/lock

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.