1

I am completely new to Elementary OS and Linux. I have tried to figure out this issue by Googling lots but cannot seem to fix it.

I have a slow boot, the following messages pop up and delay the boot by 90 seconds:

  • a start job is running for dev-mapper-cryptswap1.device
  • a start job is running for dev-disk-by(really long number)

To install Elementary OS, I added the installation ISO to 5gb Fat32 partition. (I'm guessing that's where the second start job came from)

Once I installed Elementary OS, I deleted the 5gb Fat32 partition, deleted the swap partition, that was next to it and then created a new swap partition (5gb larger).

I added the new UUID's to the /etc/fstab but still get this error.

Although, when checking the partitions in Gparted, the swap partition is 'swapon'.

Here is my /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>        

UUID=7708301d-4412-4eac-bca7-0e24914097d6 none swap sw 0 0    
UUID=14A1-9401 /boot/efi vfat umask=0077 0 1    
UUID=c330fa90-5e8f-42b4-b85b-29c4353484fc / ext4 errors=remount-ro 0 1

If I run blkid, i get this:

/dev/sda1: UUID="7708301d-4412-4eac-bca7-0e24914097d6" TYPE="swap" PARTUUID="1a5ffadf-3608-42f9-b94a-211ca54f0e7b"
/dev/sda2: UUID="14A1-9401" TYPE="vfat" PARTUUID="9643d8a5-ecd8-4f77-b27d-c1ab3e6bb8fe"
/dev/sda4: UUID="c330fa90-5e8f-42b4-b85b-29c4353484fc" TYPE="ext4" PARTUUID="e901de58-44a0-410d-b95b-64b58c548b09"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.