I dont get any updates anymore. The update windows is empty. I have also tried "sudo dpkg --configure -a" that have fix update problem before,with no luck... Please help..

enter image description here

3 Answers 3


There was some problem that messed up the update screen. Elementary released new updates that solved it. In particular, you need to install the latest packagekit package:

sudo apt-get update sudo apt-get install packagekit

Source: https://medium.com/elementaryos/important-update-released-501c9d9f28b


I don't know how to solve that problem but you can easily replace elementary's native "app centre" with some another app manangement software like Synaptic package manager. I am using it for a while and it is far better than the app centre. You could easily install it by running these commands in the terminal:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install synaptic
  • I ended up doing the same thing. I use the Gnome Software Center. "sudo apt-get install gnome-software" I find this one useful due to its GUI
    – Eosdude
    Commented Apr 11, 2017 at 18:57

I had a similar issue last week and I was able to fix it with

sudo apt-get upgrade

It installed all the missing updates and now I'm able to install updates from app center again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.