5

I'm on a fresh install.

At first, when I was trying to install an app from the app center it would say 'starting' with an empty loading bar that would remain empty forever.

After looking up some solutions I tried running sudo apt update and sudo apt upgrade, now when I try to install an app the behavior is essentially identical except it now says 'Waiting' instead of 'starting'.

EDIT: the problem no longer exists for me on 0.4.1 with the new App Center.

2

I had the same issue yesterday. I tried the update and upgrade as you said, rebooting and nothing happened. Then I followed these steps to remove and install again the AppCenter and now it's fixed. I hope it will work for you as well.

1.sudo apt-get purge appcenter
2.sudo apt-get purge packagekit
3.Restart
4.sudo apt-get install packagekit
5.sudo apt-get install appcenter
6.Restart

Edit: You can also update manually with

sudo apt-get update
sudo apt-get upgrade
Restart

In response to the comment you wrote.

  • I followed the steps you have outlined but to no avail :( – banana1 Apr 9 '17 at 17:41
  • @banana1 sorry to hear that. I can't think of anything else, I am new in elementary OS. I tried several things myself but this is what helped me. Give it a try to do the sudo apt-get update and sudo apt-get upgrade with a reboot after each command. Because I see you didn't use the -get part. – geo1230 Apr 9 '17 at 17:54
  • 1
    For me this did also not work. But was the best suggestion until now. – JoeFox Apr 12 '17 at 8:20
  • 1
    I had a different AppCenter issue: "Updates" tab totally blank despite notifications saying updates are available. This solution seemed to fix that problem, at least. – D. Hancock Apr 12 '17 at 15:25
  • @D.Hancock I had this issue. It must be a bug. If this answer helped you, please upvote it. thank you. – geo1230 Apr 12 '17 at 15:37
0

open terminal and type:

sudo apt update

Then reboot when it's done updating.

-1
  1. Sudo dpkg --configure -a
  2. Sudo apt-get update
  3. Reboot
  4. Open system settings
  5. Click about
  6. Check for update
  7. Reboot

Done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.