I have new ASUS ZenBook UX410UA and Microsoft Designer Bluetooth Mouse.

I was able to pair, connect and trust Bluetooth mouse, but it mostly doesn't work. Sometimes mouse works only few seconds after login, sometimes few minutes. Than mouse cursor will get stuck and only sometimes helps toggle on/off Bluetooth, sometimes logout, sometimes nothing and reboot is needed. Absolutely not reliable.

petr@UX410:~$ bluetoothctl
[NEW] Controller F4:8C:50:AC:FE:12 UX410 [default]
[NEW] Device F4:48:0D:AC:6B:6E Designer Mouse
[bluetooth]# info F4:48:0D:AC:6B:6E
Device F4:48:0D:AC:6B:6E
Name: Designer Mouse
Alias: Designer Mouse
Appearance: 0x03c2
Icon: input-mouse
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
UUID: Battery Service           (0000180f-0000-1000-8000-00805f9b34fb)
UUID: Human Interface Device    (00001812-0000-1000-8000-00805f9b34fb)
[bluetooth]# version
Version 5.37

I have connected/paired thru bluetoothctl utility, as Bluetooth section in Wingpanel or Switchboard Bluetooth settings not worked well for me.

lshw output here at https://pastebin.com/uuy41GhD

Any suggestions how to get this work, or is this known "in development" stage? Thank you.

  • I have the same problem with a wired mouse, after last Elementary update 4.1 It works for a short time, then i nerd to force with "pkill wingpanel" and start working for a short time again... I'm so nerd, how i can update the kernel to 4.8.? Thanks.
    – Guren
    Commented May 30, 2017 at 20:11

1 Answer 1


Update: Solved after update to new kernel 4.8 {linux-generic-hwe-16.04}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.