1

This question already has an answer here:

I am using elmentaryOS Loki.
It takes up to 20 seconds to show desktop after I enter my password.
Please help me out.
Update: I have update my Linux Kernel to 4.10 version

marked as duplicate by Daniel Foré Mar 11 '18 at 1:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5

rename the file: /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled

  • I have update my Linux Kernel to 4.10 version. is kernel update causing this problem? – Edward Torvalds Apr 9 '17 at 4:49
  • Btw, renaming that file did help. wouldn't disabling at-spi-dbus-bus create any problem in desktop? – Edward Torvalds Apr 9 '17 at 4:49
  • I have yet to have a problem after I disabled it. So I am going to say no. For others who want a command to copy and past to perform this, >sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled – Eosdude Apr 27 '17 at 22:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.