0

I have two desktop monitors that I have rotated clockwise. The systems settings feature is bugged (the "Confirm" button was not clickable), so I rotated them using xrandr:

$ xrandr --output DP1 --rotate left
$ xrandr --output VGA1 --right-of DP1 --rotate left

However, when I logout or restart, these settings get lost. Next, I decided to take the ~/config/monitors.xml:

<monitors version="1">
  <configuration>
    <clone>no</clone>
    <output name="DP1">
      <vendor>HWP</vendor>
      <product>HP ZR2440w</product>
      <serial>CN43270JLZ</serial>
      <width>1200</width>
      <height>1920</height>
      <rate>59.950172424316406</rate>
      <x>0</x>
      <y>3</y>
      <rotation>left</rotation>
      <reflect_x>no</reflect_x>
      <reflect_y>no</reflect_y>
      <primary>yes</primary>
      <presentation>no</presentation>
      <underscanning>no</underscanning>
    </output>
    <output name="VGA1">
      <vendor>DEL</vendor>
      <product>DELL 2405FPW</product>
      <serial>M675462F1E5S </serial>
      <width>1920</width>
      <height>1200</height>
      <rate>59.950172424316406</rate>
      <x>1920</x>
      <y>0</y>
      <rotation>left</rotation>
      <reflect_x>no</reflect_x>
      <reflect_y>no</reflect_y>
      <primary>no</primary>
      <presentation>no</presentation>
      <underscanning>no</underscanning>
    </output>
  </configuration>
</monitors>

and rotated them both left. However, when I logout or restart, this too gets ignored. I read about a bug of this with Ubuntu, so I thought this might apply here: But pkill -9 -f gnome-settings-daemon did not read in these settings (at least, the displays were still not rotated).

There's not much to search: All results I found for Ubuntu I tried, and for elementary OS, I found not much to begin with. Here's what xrandr reports (after manually turning the displays): How should I proceed?

DP1 connected primary 1200x1920+0+0 left (normal left inverted right x axis y axis) 520mm x 320mm
   1920x1200     59.95*+
   1920x1080     60.00    50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.95  
   1680x945      60.02  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1366x768      59.79  
   1360x768      60.02  
   1280x800      59.81  
   1280x768      59.87  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   1024x576      59.97  
   800x600       60.32    56.25  
   720x576       50.00  
   848x480       60.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 connected 1200x1920+1200+0 left (normal left inverted right x axis y axis) 520mm x 330mm
   1920x1200     59.95*+
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.08    60.00  
   800x600       75.00    60.32  
   640x480       75.00    60.00  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
0

The workaround for me (in Fedora) is restarting the Shell using Alt+F2 for the run command and typing in 'r'. This only works if you're running Gnome Shell in Xorg mode though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.