0

I can't seem to fix the wifi connection. Even if I restart Elementary, I still have no option about wifi connection.

I can only connect to internet by using Ethernet cable.

a busy cat

Is there any way to fix it?

I have already installed linux-image-generic-lts-xenial, and have disabled wifi power saving, but the wifi is still not being shown.

I believe I am not the first to have this problem, but I can't seem to find similar question in Elementary forums.

Thank you

Edit: If this helps you: When I open wifi at system settings, the tab is empty. enter image description here

Can anybody suggest anything else? None of the solutions provided already works.

Edit: So, no one has experienced this kind of problem before?

0

It might be that your network manager needs restarted.

Try

sudo service network-manager restart
  • 1
    thank you for your reply. Unfortunately, no change is made if I restart network manager. – Snow Apr 4 '17 at 23:49
  • Also, I have already installed linux-image-generic-lts-xenial, but wifi does not show up. – Snow Apr 4 '17 at 23:56
  • Is wifi available if your running from a live USB? – Sean Patterson Apr 5 '17 at 10:35
  • Unfortunately, I don't own a live USB. But two days ago Wifi was working just fine. I think after I updated Elementary, it showed problems. Also in Windows Wifi works fine. – Snow Apr 5 '17 at 12:13
  • What method did you install elementary? – Sean Patterson Apr 5 '17 at 12:20
0

Considering you mentioned that it worked during the Live CD/Install. I would try disabling Secure Boot via your BIOS or you could also use Mokutil to do so:

sudo apt install mokutil sudo mokutil --disable-validation

It will ask you to create a password that is at least 8 characters long. Next you will need to reboot into Ubuntu and it will ask you to confirm the password that you created. It might ask for individual letters to be typed in instead of the entire password

Let me know how it goes!

  • I tried that, but EFI variables are not supported on my system. – Snow Apr 7 '17 at 15:42
0

Apparently, I had to reinstall bcmwl-kernel-source:

sudo apt-get install bcmwl-kernel-source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.