I am trying to install elementary OS on the new XPS 9560.

It comes with windows 10 home. I have installed it, and I have resized my SSD by about half.

I currently have around 480 GB of unallocated space.

I then rufus up a bootable USB with correct hash.

I then boot it up and get to the install mode. But when I come to the part of "Installation type" it doesn't see any device and I don't have access to gparted or anything.

Is this a common occurance?

Hope someone can help. Thanks in advance.

2 Answers 2


Tried to install E OS on my dell xps 9550 and found the solution for your problem while searching for mine (how ironic)

1 Reset BIOS settings to default

2 Boot windows

3 Run command 'msconfig '

4 Tab 'boot' and tap 'safe mode'

5 Restart, enter BIOS and switch RAID to AHCI

6 Restart and windows will boot in Safe mode.

7 Run msconfig and untap safe mode.

8 Restart, insert USB and boot ubuntu.

9 This time it will locatie your SSD drive.

Pls note that this will not work for a HDD

  • This should work... AHCI is one of the key values for disk drives and linux Commented Jul 23, 2017 at 1:29

For my small company, the Dell XPS 13's are a great fit but don't come with Linux on the cutting edge touchscreens / etc. Linux / elementary / manjaro / ubuntu are all best for our engineers and GIS crew, but there still remain some industry-specific software we need windows for (Pix4d).

We've finally perfected the dual boot installation process after destroying and reinstalling too many OS's... here's what we do.... Most used machine: Dell XPS 13, Windows 10 already installed, no linux yet, often we use Elementary OS

The Definitive XPS 13 dual-boot how to :

  • Make sure Linux USB boot image is created using WINDOWS (so it boots UEFI style, we use Rufus)
  • Windows Partition Manager --> shrink so unallocated space is available for Linux
  • Windows Settings --> Power Options --> Advanced --> Change what power button does --> Allow changes to settings --> turn off fastboot
  • Run 'msconfig' --> boot tab --> safe mode to ON
  • Restart, enter BIOS and switch RAID to AHCI (use f2 on dell logo)
  • Restart and windows will boot in Safe mode
  • Run msconfig again and unselect safe mode
  • Restart, insert USB the moment the computer power toggles
  • F2 again into bios settings, make sure boot sequence is USB first, Windows second
  • Apply and exit
  • Allow system to boot from and install Linux
  • When installer asks about 'partition' --> 'boot alongside windows'
  • let installer do the rest
  • Restart
  • You're done. Choose OS and go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.