I'm trying to get into developing for Elementary using Vala. I have been unsuccessfully trying to build Valama (an IDE for Vala) for ages but keep hitting hurdles.

Currently when I try to make Valama (having satisfied all dependencies) I get the following error:

error: Package 'webkit2gtk-3.0' not found in specified Vala API directories or GObject-Introspection GIR directories

I have apt-get install'd both webkit2gtk-3.0 and webkit2gtk-3.0-dev but the error persists. Any idea how to fix this?

2 Answers 2


For this kind of errors I always search in the AUR for missing dependencies, when I install all the dependencies the problem, most of times fixes, if not you should read the oficial git/webpage because maybe it can have bugs. So check out if you have installed this packages:

  • clutter-gtk
  • gdk-pixbuf2
  • gdl
  • glade
  • glib2
  • gtksourceview3
  • intltool
  • libgee
  • webkit2gtk
  • cmake
  • imagemagick
  • vala-0.26

I hope this information will help you, for me worked like a charm.


The error message is coming from the Vala compiler and suggests the VAPI file is not being found for webkit2gtk-3.0. It looks likes Valama fixed this by adding webkit2gtk-3.0.vapi to its repository with this commit:

CMake: Add webkit2gtk-3.0 vapi to support vala < 0.26

Maybe that helps you a little. I tried building Valama on Fedora 23, but CMake reports:

-- Package 'webkit2gtk-3.0' not found CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:360 (message): A required package was not found

This is to do with the pkg-config file webkit2gtk-3.0.pc not being found. I didn't try any futher to repeat the error message you are getting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.