3

Having problems with NVIDIA GPU not detecting displays properly. I have 1 external monitor, and a laptop screen Using Elementary Freya 0.3 x64 and NVIDIA binary driver 355.06, everything is up to date.

Resolutions:

  • laptop: 1366x768
  • monitor: 1360x768

both monitors support 60Hz refresh rate, but their refresh rates are much lower, I'm noticing some slight mouse pointer delay.

xorg.conf ad xrand: xorg_xrandr_pastebin

X Server Display Configuration Layout is following: enter image description here

lspci -nn | grep '\[03'
  • 00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)

  • 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119M [GeForce GT 520M] [10de:1050] (rev a1)

Anyone has any idea what could be causing this, maybe faulty GPU or something ? Integrated Intel is detecting everything properly.

I've also tried manually configuring xorg, but I can't seem to find any decent way to set up refresh rate, since all the command I've been able to dig up on google are using deprecated commands etc. so I'd appreciate if someone has an idea/way to manually configure the layout.

Thanks.

4
  • Please, can you post model and vendor monitor?
    – bitseater
    Aug 6, 2015 at 12:04
  • samsung syncmaster 933
    – valaya
    Aug 7, 2015 at 1:50
  • please did u solve this problem? I have exactly the same on my notebook, I tried everything but nothing works. I changes xorg.conf in all possible ways but nothing makes changes. I am running nvidia driver 352.63 with Nvidia GTX860M Thank you very much! Jan 5, 2016 at 11:54
  • How did you install the drivers? From the Additional Drivers window or by yourself?
    – codehitman
    Jan 5, 2016 at 15:59

1 Answer 1

1

This message in the picture :

X Screen 0 (No Scanout)

makes me think that xorg is not detecting your monitor vendor.

Connect the monitor to the laptop, start it and login. Try the buttons on the monitor, enter in the OSD menu, go to SETUP > Reset.

After this, go to Configuration > Displays in your desktop. Monitor will go to blank for one second and you will see the correct resolution and your monitor vendor.

13
  • Doesn't help, Nvidia X server's still not recognizing the layout. The system's display settings detect the monitor and resolution, but doesn't allow me to change the samsung monitor to primary monitor.
    – valaya
    Aug 7, 2015 at 11:54
  • If you are using a VGA connector to attach the monitor, the system identifies as CTR. Your xorg configuration don't allow CTR monitors. Change it in Screen section, option "IgnoreDisplayDevices". Feedback will aprecciated.
    – bitseater
    Aug 7, 2015 at 12:21
  • After removing that line, it manages to detect this, at first login: firstLogin I'm able to set refresh rate and resolution on samsung. When I open Freya's display settings, this happens (I've wanted to set samsung as primary monitor) freya settings
    – valaya
    Aug 7, 2015 at 20:50
  • Sorry but it seems the same pic in both links
    – bitseater
    Aug 7, 2015 at 21:00
  • yea, my bad, didn't notice. here's the 2nd picture i.imgur.com/ROkWPE1.jpg
    – valaya
    Aug 7, 2015 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.