I just installed elementary OS Loki on my Lenovo yoga 3 pro and can't get the to work. Any suggestions for me?


The Broadcom wifi chipset requires a proprietary driver to work.

Run these commands to install and enable it.

sudo apt-get install bcmwl-kernel-source
sudo modprobe -r ideapad_laptop

More on this how-to

  • i.stack.imgur.com/kDvkn.jpg I tried entering the code you suggested, and this is all that came up. Any other suggestions of what I could do?
    – tsfish14
    Mar 27 '17 at 10:20
  • I left a question as an answer because the comment section wouldn't let me put pictures in. Thanks for the suggestions
    – tsfish14
    Mar 27 '17 at 10:22

I have found a better solution for it.

For newer versions

Check if the secure boot is disabled.

Then check the kernel version is 5.0.x

then do install git.

After that

sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)
git clone https://github.com/tomaspinho/rtl8821ce
cd rtl8821ce
chmod +x dkms-install.sh
chmod +x dkms-remove.sh
sudo ./dkms-install.sh

Now the touchpad issue... just go to settings > mouse and touchpad

then change the option of physical clicking from multi-touch to touchpad areas.

It is for the older versions of elementary os.

I have a Lenovo Ideapad 330 15ARR with Ryzen 3 processor. I tried to install ubuntu using legacy mode and UEFI mode, but both were showing only a blank screen.

After 10 days of trying different methods, I found out a way to install it.

The actual problem why it was not working is that the ubuntu installation file comes with a kernel that doesn't support the display/video graphics of this laptop.

So to overcome this, you have to add a parameter to the ‘install Ubuntu’ option in the grub menu.

You can press ‘e’ when the ‘install Ubuntu’ option is highlighted to enter the command section.

You can find a line starting with ‘Linux’ and ‘quiet splash’ somewhere at the end.

Edit that line and add ‘nomodeset’ before ‘quiet splash’.

Then go back and install ubuntu.

If the grub menu doesn't show up at booting, go to BIOS (by pressing F12 at boot) and in boot option, select ‘Ubuntu’.

When the grub menu appears, you have to add the ‘nomodeset’ parameter again for ubuntu to load. You won't be able to adjust brightness.

After booting, update ubuntu - including kernels.

U can use ukuu to update the kernel.

After that, you won't have to add nomodeset parameter each time at booting.

The latest kernel has a problem with wifi and trackpad, so it is better to install a 4.17.xx version of the kernel using ukuu.

Hope this helps.

  • Your participation is much appreciated👍 Let me inform you that we love informative answers with step by step guide. Please try to include the answer here and leave the source link. Have a nice day!
    – Hasan
    Jan 18 '20 at 21:57
  • @Hasan already done that
    – Bugs BUNNY
    Jan 20 '20 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.