My hardrive was damaged so I had to change it, after so I was given mac osx mavericks I think, I decided to install linux with packaging version of ubuntu 16.0 LTS in ElementaryOS,I made a partition of the hardrive on OSX with disk utilities, I installed rEFInd and installed Linux from a USB by disabling AMD graphic card,I had many problems dealing with ElementaryOS due to AMD graphic cards during this period, after Linux installation rEFInd was uninstalled so I reinstalled rEFInd from OSX which lasted a long time booting(which was the last time I ever boot into OSX on my mac) and at the end after disabling AMD card on Linux booting for grub everything worked fine for linux, but after disabling the graphic card and saving changes to grub in Linux I was no longer available to boot on OSX, rEFInd was showing with OSX option but when I click it , the Apple Logo appeared and then a white/gray apple familiar looking screen showed up and then up to 20 minutes of waiting OSX didn't boot so I needed to turn down the computer, there was another option in grub's options which launched me a

panic(cpu 98 caller 0xffffff80002aa36b): "pmap_map_bd: Invalid kernel addres\n "0/SourceCache/xnu-1699.32.7/osfnk/l386/pmap_x86_common.co:1470 Debuggercalled : Backtrace (CPU 8), Frame: Return Address 0xffffff8000010be68 [.....and more lines]

which I don't know what it means, now I cannot even start recovery mode on mac I don't know what I've done, I am sure I did right partitions on OSX which by now I can see with linux where OSX is installed in sda2 a courious thing is that with the linux program that manages partitios a message says: No support tools were found for file systems currently present on hard disks in this computer:

Partition File System Support Tools URL /dev/sda2hfsplushfsplus /dev/sda3hfsplushfsplus As long as the support tools for these file systems are not installed you will not be able to modify them.

You should find packages with these support tools in your distribution's package manager.

which make reference to the sda 2 partition where OSX is intalled.

Help please

1 Answer 1


For me, recovery mode is automatic if the hard drive is blank and will try to talk to Apple via a network connection to install MacOS, run Disk Utility, Terminal, etc., though it takes a while. You should also be able to enter recovery mode by holding down Command+R at system start.

All rEFInd or rEFIt do is save you the time of having to hold down the Option key at system start in order to choose the proper partition/hard drive/DVD to boot from. You should be able to choose MacOS from that menu.

Have you tried clearing your NVRAM? https://support.apple.com/en-us/HT204063. It's helped me a few times, for whatever reason, when my MacBook wants to act like an ass.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.