Maybe a stupid question. Anyway, how do I run an application from within the applications folder (/usr/share/applications)? There is no run option from within the context menu (mouse right click).Thanks.

1 Answer 1


The files in /usr/share/applications are just desktop configuration files for the Applications menu. They are not the actual applications. In fact, if you were to view one of these text files using the Scratch text editor, you'll see that a lot of the files contain the location of the actual binary files, which you CAN run directly from the terminal (some don't have complete executable path locations, because they are already in the default user path). Hope this helps!

  • 1
    @ Paul Smith:I was trying to find out if in pantheon-files had the equivalent of what I have with Nautilus (double click the desktop file, and it will run the app). I solved the problem by installing nautilus. Mar 23, 2017 at 16:27
  • Ah, I see. I wasn't aware that Nautilus could do that... Cool!
    – Paul Smith
    Mar 25, 2017 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.