0

Just like this post I have been traditionally a windows user and would like to have my buttons on the right hand side.

I couldn't find org.pantheon.desktop.gala.appearance button-layout but did have org.gnome.desktop.wm.preferences button-layout. I changed the settings to **':minimize,maximize,close'* logged out and nothing and then restarted and nothing. The settings are there but have not taken effect.

Im on OS X El Capitan and used the gsettings set org.gnome.desktop.wm.preferences button-layout :minimize,maximize,close command. I have read online that this particular version was designed to block customization much more than previously available and have not been able to find a working solution online.

Any suggestions?

1

Installing elementary tweaks would be an easy graphical solution of customizing your system.

Here's a link to the git repo https://github.com/elementary-tweaks/elementary-tweaks

It is true that elementary os loki does block customization by not having the software-properties-common package preinstalled. Without this package you cannot a PPA to your system.

Installing elementary-tweaks

sudo apt-get install software-properties-common

sudo add-apt-repository ppa:philip.scott/elementary-tweaks

sudo apt-get update

sudo apt-get install elementary-tweaks

  • Im on OS X which does not have apt-get. I do have brew is there is an alternate solution with that tool. – Endorox Mar 10 '17 at 20:36
  • I installed Fink as a work around for sudo apt-get but I had serious problems with my work firewall and the program so I removed it. So there is a way to get sudo apt-get but it takes several extra tools to get it going. – Endorox Mar 10 '17 at 22:15
1

You can use:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DialogsUseHeader': <0>, 'Gtk/ShellShowsAppMenu': <0>, 'Gtk/DecorationLayout': <':close,minimize,maximize'>}"

from terminal.

  • org.gnome.settings-daemon.plugins.xsettings does not exist. – Endorox Mar 10 '17 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.