0

As stated in the question: is it possible to enable back-cycling through open applications when using alt-tab? Eg., pressing alt-tab goes one app forward, and pressing alt-shift-tab goes one app backward?

2
  • you should mark the answer as definitive if that was what you were looking for
    – user170
    Commented Mar 7, 2017 at 21:54
  • Yah, there you go.
    – Potato
    Commented Mar 8, 2017 at 9:51

2 Answers 2

3

Switch windows: Shift-Tab.

Switch windows backward: Shift-Alt-Tab.

enter image description here

You can changed that if you want.

3
  • God, I haven't even noticed that! Thank you! I intuitively tried pressing alt+shift+tab and noticed it isn't working, so I went on to ask a question. Now I realized the thing was that i always started cycling with alt-tab and then pressed shift, which stops the cycling. Meaning that you can go from backward-cycling to forward-cycling, but not the other way around... That's mildly irritating, but thank you for pointing out that the option exists!
    – Potato
    Commented Mar 6, 2017 at 17:36
  • Yeah, I know that it works that way, but after taking my fingers off the keyboard, the plank showing the open programs closes. What I'm getting at is this: you can press alt-tab-shift to backward-cycle, and when you release the shift key, you can still use the alt-tab combo without the plank showing the open apps disappearing. But when you start forward-cycling, you can't switch to back-cycling without the plank disappearing.
    – Potato
    Commented Mar 7, 2017 at 17:39
  • I think it would be better for the user experience to keep the plank with the open apps present during the cycling process, and enable the user to seamlessly switch between forward and backward-cycling. That way, you can always see where you currently stand, in which direction, and how far you want to go.
    – Potato
    Commented Mar 7, 2017 at 17:42
3

I just encountered an issue related to this in elementaryOS 6 (Odin). The Alt+Shift shortcut for switching keyboard layouts was interfering with the default Alt+Shift+Tab shortcut for cycling backwards in the window switcher.

Disabling or changing the Switch layout shortcut did the trick for me.Settings -> Keyboard

1
  • 1
    This fixed it for me! Commented Aug 23, 2021 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.