1

So i tried installing DiscordApp and it tells me i got broken dependencies and that i need to run "Sudo apt-get install -f"

However doing that yields this error:

 Errors were encountered while processing:
  /var/cache/apt/archives/linux-image-4.4.0-64-generic_4.4.0-64.85_amd64.deb
  /var/cache/apt/archives/linux-image-4.4.0-62-generic_4.4.0-62.83_amd64.deb
 E: Sub-process /usr/bin/dpkg returned an error code (1)

Full log for install -f: http://pastebin.com/yy27igpT

I also tried running sudo apt autoremove which also yields a similar problem.

(log for autoremove: http://pastebin.com/PXf7H9pT)

Elementary Os is my first linux distro, i'm really liking it so far but since this error occured i have been unable to install programs, updating and similar so it's really blocking me :(

Anyone out there knows how to fix this?

Solution: Follow the solution steps on https://askubuntu.com/questions/345588/what-is-the-safest-way-to-clean-up-boot-partition#345611

2

The error message says there is no more space on the disk. Try to remove some packages or delete other files before running apt-get autoremove or install.

  • But i got 127 gb free on my hard drive? Also how do i delete individual packages? – Empa Mar 6 '17 at 15:33
  • Try to look at df /boot in a terminal (I think the /boot is full where kernel images are stored) – lemonslice Mar 6 '17 at 18:01
  • 1
    Thank you for your help! This lead me to find this: askubuntu.com/questions/345588/… Which helped me solve the problem! – Empa Mar 7 '17 at 10:12
0

Use gdebi for everything. In order to install Discord properly you have to use:

sudo gdebi discord-0.0.1.deb (or whatever version you have)

It should and will install this application silently.

  • Thanks! I will from now on, never even heard of gdebi before – Empa Mar 9 '17 at 15:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.