0

Tried to add to the question below, but I don't have the rep yet, so new question
No Internet connection after an updte OS Loki

Short version: triple boot Win XP, Xubuntu, elementary. Network won't connect after OS update, ethernet only, no wifi on this machine. Similar happened in Zorin. Xubuntu working. Win XP working.

Three key points:
- I looked at the versions of libnl-3-200, libnl-genl-3-200 and libnl-route-3-200 (in case a downgrade might help) on Xubuntu, elementary installation and elementary live CD. They're all the same version, so I'm guessing the problem isn't here.
- In Xubuntu, ethernet visible and connected, sudo ifconfig -a shows outputs for eth0 and lo. elementary show lo but no eth0
- Network manager is missing the Network icon. Description in 2nd comment.

Longer version:
Linux noob - patience please!
Start with Win XP
10-yr-old old desktop, ethernet only, no wifi
Try live CD elementary Loki. Impressed with elementary's approach - curated=uncluttered, easy to use, easy to find and launch applications, while still having the power and control of commands via terminal, with a very good looking interface
Install elementary Loki as dual boot
After a recent update January 2017, network connection stops working
Try to find causes and solutions at this forum (keywords ethernet, lan, connection, internet, eth0, and prob others) and around the internet. Find no fix
No network problems in either WinXP or elementary live CD Wipe and reinstall elementary Loki, network working. Install all updates and upgrades, network does not work
Install Lubuntu (as of Ubuntu 16.04.1) as triple boot
Try other Linuxes (have tried several Linux live CDs, and for a bit of fun, Haiku and GhostBSD live)
Wipe Lubuntu and install Ubuntu. A little slow on my system (still faster than XP which has never been wiped and reinstalled.) Install Metacity with Ubuntu, fast enough, but keep exploring
Wipe Ubuntu and install Xubuntu. Fast enough, and will probably stick with this as main Linux OS and probably eventually dump Windows on this machine Try to find elementaryOS "no network" causes and solutions at this forum and around the internet. Find no fix
Wanted to try Zorin at some point anyway, wipe elementary and install Zorin. Network connection works. A bit slow on my system
Install all updates and upgrades, network connection stops working Wipe Zorin, reinstall elementary
Install elementary updates individually, except OS update
Network connection still operating, even with Network Manager update
Install OS update, network connection stops working

I can reconstruct at least some of the specific steps I took if it would help (but not all steps, since I foolishly didn't keep step-by-step notes.)

  • Also: Network manager - VPN and Proxy icons visible, Network icon missing (was there before updates), "Airplane Mode is Enabled" doesn't change if I toggle airplane mode button – TheTKS Mar 4 '17 at 16:18
1

Specific problem with my blacklisted Broadcom driver. Ethernet connection working now thanks to solutions found in two askubuntu posts. I have no wifi adapter.

Ethernet Network card BCM4401-B0 no longer recognised? 1
How to Revive Wired Internet and Setup Wireless? 2

sudo modprobe b44 temporarily restored my connection. I then installed gedit to allow me to edit permanent or semi-permanent fixes into */etc/modprobe.d/blacklist-bcm43.conf

  • Open question, still: while this solution persists after reboot, it may not persist after updates to bcmwl-kernel-source.postinst and may need to be repeated at that time. Could an edit in bcmwl-kernel-source.postinst make this change permanent? – TheTKS Mar 14 '17 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.