5

having a lot of trouble mounting and reading an SD card in Elementary. I'm running the latest Elementary, all up to date, on a Lenovo Thinkpad T450s.

I got a new SD card and plugged it in. Couldn't read because it was exFAT; no problem, I used the Disks app to reformat it to NTFS. Now it mounted, but when I tried to move some of my music over, it worked fine for about 1 gig and then slowed to 80 kilbytes per second. I did this whole thing over again and the same thing happened again. My next attempt to reformat failed.

At this point I thought I had bought a bad card, but I rebooted into Windows 10, reformatted NTFS, and transferred a full 100 gigs of music over, no problem. I checked a few songs at random, everything was fine. Booted back into Elementary, and the SD card would show up in the file manager but wouldn't be able to mount. It showed up in the Disks app as "Partition Type: unknown". Not able to mount or mount.cifs in terminal.

Now I've rebooted again and it doesn't show up at all. Still shows up in Disks as "Partition Type: unknown".

Here's the dmesg tail immediately after I insert the card:

[   66.089049] mmc0: new ultra high speed SDR104 SDXC card at address 0007
[   66.093405] mmcblk0: mmc0:0007 5&DRP 119 GiB 
[   66.094242]  mmcblk0: p1
[   66.136799] mmcblk0: unknown error -22 sending read/write command, card status 0x900
[   66.304671] mmc0: tried to reset card
[   66.304687] blk_update_request: I/O error, dev mmcblk0, sector 2048

I've seen scattered threads throughout Reddit and Stack Exchange but people seem to have had limited success. Any help would be appreciated, thanks.

[EDIT] I've seen some suggestions that the SDXC card only officially supports the exFAT filesystem. So I reformatted the card with the official SD Association's utility, and on the Elementary side I installed exfat-fuse and exfat-utils. The card now reads but very unreliably -- just opening a folder will frequently cause my file manager to lock up.

  • What FS is your eOS install on? – Sean Patterson Mar 9 '17 at 14:12
  • FS = filesystem? ext4 – Lucas Mar 10 '17 at 16:11
  • OK, the reason I ask is I recently installed on a machine using btrfs and I was experiencing issues with USB storage. But on ext4 that shouldn't be the problem. – Sean Patterson Mar 10 '17 at 16:16
  • Interesting. I have had this for a long while. It also happens on my Ubuntu 16.04 machine, so it is likely no just Elementary OS itself. I just boot into Windows now. I now my comment doesn't help you, but you're not alone. – Eosdude Mar 31 '17 at 19:45
  • @SouperSoup That does help, thanks for commenting. Now I know it's not something I specifically did wrong! – Lucas Apr 1 '17 at 20:20
1

I would keep SD cards fat32 format. You can install gparted and format it. unmount it first than format the SD card. I do not know what you would gain from ntfs on a SD card.

-1

Have you tried to format your sdcard as fat 32?

sudo mkfs.vfat -I /dev/sd#

# is your device name

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.