0

I have a Portuguese (pt-br) keyboard on my thinkpad and it have by default a special key that its not on standard place. They key is the "Question Mark + Slash".

To make it work I always use the following command:

sudo setxkbmap -model thinkpad60 -layout br

But since my last update of elementary (01.March.2017) this command does not work anymore, so now the key is dead.

I found a way to enable it temporarily, but it only works for the active session. After restarting, I need to do the process again:

sudo dpkg-reconfigure keyboard-configuratio

So, is there a way to setup it correctly? Without losing the settings after restart?

Thanks.

enter image description here

1

After many researches I found what was happening. The settings (from thinkpad + br) was being interfered by an additional options added by another model (korean).

How I solved:

First, checking the layout info with:

# setxkbmap -query
rules:      evdev
model:      thinkpad60
layout:     br
options:    korean:ralt_rctrl,grp:shifts_toggle

Second, setting options to none with empty quotes:

# setxkbmap -model thinkpad60 -layout br -option ''

Now all the keyboard is working fine, AltGr, question mark + slash, characters used with AltGr.

In addiction, add the same command line in the .bashrc file (on your home folder) on the last line file. It will run the script everytime you resume from sleep mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.