0

I have an AppImage executable file which I need to run on startup. I have given the file permissions to execute, it is currently 764.

To open the application from terminal, I just the type the path, and it starts. I entered this path as a Custom Command in Settings->Applications->Startup . But it doesn't open on startup. How do i do this?

  • If you execute the same command through terminal, does it work correctly, or do you get an error message? – Ryan DeBeasi Mar 1 '17 at 18:07
  • @RyanDeBeasi It works correctly. I was able to get it working by locating the .desktop file and copying it to autostart folder. – thegreyd Mar 2 '17 at 17:31
3

Got it working by copying the relevant .desktop file from ~/.local/share/applications/ to ~/.config/autostart.

The AppImage I downloaded, when run the first time, gave an option to add shortcut file, which is how the .desktop file got in the local folder.

Thanks to this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.