2

this is my first experience on Elementary OS and I'm pretty new to Linux/Ubuntu. I find my way around pretty easily with Google at my fingertips. Somehow I could not find any sources about the following case.

I have installed Elementary OS on my SSD (full drive, EXT4). I also have 6 HDD that I configured as a RAID-Z zpool and setup a zfs filesystem on top of that zpool.

Somehow, I configured the mount option to be /data.

The issue is I would like this "drive" to appear as a "partition" under the Devices section in the sidebar of the pantheon-files application. pantheon-files I would like it right under "File System" since it's an actual drive.

Thank you very much for your help.


EDIT:

I agree that the questions are similar, after re-reading it. But there is not a really satisfactory answer since the only answer is as follow.

Actually none of the partitions mounted permanently (except the / partition) shows up in this Devices list, only external USB or network drives. This seems to be a limitation of the underlying software library.

But in my case, I can see that I also have a mounted drive (PHOTOARCHIVE), which is in a SATA dock connected directly to my motherboard (so not USB). That means the answer is either wrong or incomplete since my hard drive appears there. By the way, that drive was mounted under /media/{username}/PHOTOARCHIVE/.

Before I can say an answer is valid, it has to actually tell me something more than "not possible". Is there something I can do to test? If it is a limitation of the underlying software library, could I know which one(s). That way I could investigate / broaden my search and maybe open a bug report in the correct project.

Thank you very much.

  • Possible duplicate of Home partition not showing in Files sidebar – lemonslice Feb 28 '17 at 14:49
  • Hello, I did found this question, but did not really understand it as being the same. Now that I re-read it, you might be right. But is there any other option? For example, that "PHOTOARCHIVE" drive you can see in my screenshot is an actual hard disk plugged in a SATA connector. – E2zin Feb 28 '17 at 17:44
  • 1
    Sorry but there is no option for now, drives mounted as part of your filesystem are not displayed. You can always drag&drop them under the Personal bookmarks, however – lemonslice Feb 28 '17 at 23:17
  • 1
    Glib VolumeMonitor is used: valadoc.org/gio-2.0/GLib.VolumeMonitor.html (in src/View/Sidebar.vala). – lemonslice Mar 1 '17 at 10:46
2

I do not have experience of zfs RAID drives but if the underlying system can handle it and it is mountable when you boot/log in then a suitable entry in /etc/fstab should allow it to appear as a device in Files. For example this line:

//192.168.0.16/Anonymous /media/jeremy/Anonymous cifs guest,uid=1000 0 0

mounts a samba server as a device.

The general format is |device| |mount location| |filetype| |other parameters ....|

You may need to Google a bit to determine the correct line to add (remember to back up the existing file!).

You will need to specify either UUID or device ID (e.g. /dev/sdc1) and create a folder under /media/username/ where it can be mounted.

  • 1
    Thank you Jeremy, I have tried adding it to the fstab, and it did appear but clicking on it (to mount it) threw an error. I will try to reproduce tonight to give more information. – E2zin Mar 3 '17 at 22:10
2

I have finally found an answer, thanks to the suggestion of Jeremy Wooten and some official ZFS documentation.

After a lot of trials and errors, here are the steps to undertake.

  1. Change the ZFS filesystem's mountpoint to legacy

    ~$ zfs set mountpoint=legacy {poolname}
    
  2. Add the following line to /etc/fstab

    {poolname}  /media/{username}/Data  zfs defaults,nofail 0   2
    

    What this does is mount {poolname} to /media/{username}/Data with the defaults mount options, and nofail to skip any failure messages that would block the boot process. In my case, because ZFS is not loaded at that point.

  3. Since the mount fails at boot time, the drive was not automatically mounted. To fix this, we need to call mount again after boot is completed. Since it needed to be mounted by root, which can be run automatically after boot inside /etc/rc.local.

    # Mount all drives after boot
    mount -a
    
    exit 0
    

That's it.

Now I have Data visible right under my File System in Devices, and I can see the space usage at a glance, and it just feels right!

Picture or it didn't happen: enter image description here

1

No matter the filesystem type, so long as it is mounted under /media/user/SomeDirectory, it appears to show up under "Devices" for me at least...

0

Actually by default none of the partitions mounted permanently (except the / partition) shows up in this Devices list as long as it is not mounted under /media.

However, you can change this behavior by adding x-gvfs-show to the mount options in /etc/fstab like this:

UUID=f5aa03f7-28a4-435e-84d6-d84529f13532 /data       zfs     defaults,x-gvfs-show  0   2
  • Thank you lemonslice, I have two follow-up questions to make this a better answer. Could you tell me how to find the UUID of the ZFS partition? Also, if I have to add these options to the fstab, does it fix the issue with default ZFS mountpoint, or should I leave it as legacy? Thanks – E2zin Apr 3 '17 at 17:04
  • As for the UUID you should check with sudo blkid. As for the mount issue, I am not sure at all… – lemonslice Apr 3 '17 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.