2

I cannot accentuate vowels (or any other letter) in the chat of Skype using dead keys (in the Spanish keyboard-layout) as I do in other applications, where I type "´" and then "e", resulting in "é".

In Skype will appear "´e" instead of "é" . This is relevant because I frequently write in Spanish, a language in which accents are important.

The problem is not with the system itself, nor the keyboard-layout, since I can accentuate in any other application, like for example in here áéíóú. Also, I believe it is not related with the language set for Skype, provided I tried out different possibilities.

EDIT: As indicated by @cipricus, this problem does not seem to be a qt issue. Therefore this question is not a duplicate of How to use the compose key in Qt apps?, and the solution provided there (install the package ibus-qt4) does not work in this case. See the comments by @cipricus for more information.

  • Do you know whether Skype on Ubuntu 16.04 has this problem? – Magnus Teekivi Feb 27 '17 at 14:46
  • From what I found on the Internet, seems not. Very scarce comments about what would be a common problem. I could only find this thread from 2009 about the same problem. It says one must uncheck the "use input method engines (IME) to enter complex characters" option in Language, yet I don't have such checkbox there. Do you know how could I uncheck it from the console? P.D.: I should have said I have the system set in English. – Hugo Baltasar Feb 27 '17 at 15:09
  • What keyboard layout are you using? -- I can confirm this with 'US-International with dead keys'. It looks like the dead keys are disabled in Skype. But the French or Romanian layouts that type the diacritics/accents directly are not affected. I think the same with Spanish. – user170 Feb 27 '17 at 15:40
  • I use the Spanish layout, and all characters work properly in any other application. Except in Skype, I can type directly every accent or special letter, like ñ. – Hugo Baltasar Feb 27 '17 at 15:52
  • 2
    @lemonslice - As indicated in my answer installing ibus-qt4 doesn't fix this at all, while ibus-daemon --xim at startup fixes it without ibus-qt4 being installed. -- Dead-keys is obviously a different problem; even if the two had the same cause (like this bug) they are still separated. - Both solutions that I have posted work and none seems to concern qt, but are maybe closer to this bug involving gnome-language-selector. – user170 Feb 27 '17 at 22:55
4

I can confirm your problem with all keyboard layouts that use dead-keys.

The Spanish layout uses dead keys to type certain characters.

As you say in a comment:

I type " ´ " and then " e ", resulting in " é "


My favorite solution is:

sudo apt install language-selector-gnome

From Applications/Slingshot launch 'Language Support' (gnome-language-selector - part of language-selector-gnome).

Set 'Keyboard method input system' to 'XIM'.

enter image description here

Log out and back.


This problem seems partially related to this askubuntu question: Dead keys (accents) stopped working after upgrading to Ubuntu 16.04 and even to this bug which refers to Spanish, with the notable difference that here only Skype is affected.


As indicated here, this may seem related to a more general problem affecting Qt applications. Trying the solution thereunder (install and run qtconfig-qt4, go to the Interface tab,under Default Input Method, select ibus) it doesn't seem to work. (Initially only xim is available there, not ibus; but that option appears after installing ibus-qt4. Enabling that option doesn't fix our problem though.) - Possibly this is not a qt issue.


There seems to be a temporary fix indicated in the answer under the askubuntu linked question that says to open a terminal and type ibus-setup.

I did that and got this:

enter image description here

Then I pressed Yes and got this:

enter image description here

As those settings doesn't seem available in elementary, I just went to Skype and now the dead keys work.

But only before logout.

It seems the ibus service is installed but elementary doesn't need that, while Skype needs it. You can start it with your session (according to How to add iBus to start up applications?) by going to Settings-Applications-Startup, press the plus in the left down corner and add the command

ibus-daemon --xim.

(Adding just ibus-daemon as indicated in another answer under that linked question doesn't fix it.).

  • 1
    It worked! Really nice one! Thanks not only for the solution but for the additional information as well! – Hugo Baltasar Feb 27 '17 at 16:40
  • Cipricus solution worked on Elementary OS, simply amazing, super thanks. – Reinaldo Camargo Apr 20 '17 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.