2

I want to automatically start the telegram desktop client when I login. But it doesn't show there when I try to add it in Settings-Applications-Startup

enter image description here

But its desktop launcher file is in ~/.local/share/applications.

menu starter

Do I have to link the .desktop file somewhere?

  • what do you want exactly? - to be able to launch the program from Applications (as you say in the title) or to have it running at startup (as you say in the question body)? or BOTH? they are different questions. – user170 Feb 26 '17 at 21:15
  • Yeah I got a bit confusing in the Titel :D I want to have it launch on boot and in the settings menu for that it doesn't show up, in the app launcher it does though. – MrGreenTea Feb 28 '17 at 9:35
  • I will edit your title then, if you don't mind, and then I'll try to edit the answer, as it is the obvious one, although in a comment you note a separate solution. Why don't you post that as an answer for others?. (Keep in mind that questions and answers here are also meant to help others in the future and not just the OP: otherwise why not delete them when a solution is reached? ;)) -- - I now understand that the Applications/Slingshot images have the purpose to show that your app is really installed. But probably the first image is not useful (although it may signal a separate problem) – user170 Feb 28 '17 at 12:16
  • Yeah, I also wanted to check if this might be a bug. If it is, I should probably create bug report on launchpad. – MrGreenTea Feb 28 '17 at 14:01
1

In some cases installed applications are not present in the available list of applications that can be added to the startup list, but you could just add the path to your application executable into the "command box" (the little box where you can add a custom command to run)

/path/to/telegram-folder/Telegram --

enter image description here

Press enter and make sure it is ticked to run and you should be fine.

  • 1
    Thanks, I got it working by linking the .desktop file to ~/.config/autostart :) – MrGreenTea Feb 28 '17 at 9:37
  • instead of the path to the executable, it is also possible to use the command gtk-launch desktop-file-name.desktop or just gtk-launch desktop-file-name (where "desktop-file-name" is the name of your .desktop file in ~/.local/share/applications) after installing gtk-launch (more here). – user170 Feb 28 '17 at 12:24
1

I got it working by linking the .desktop file to ~/.config/autostart.

I still think it's a bit confusing that the app list in that specific settings page is different than what is shown in the application starter.

0

I think the way to do it is to add the path to the executable, as indicated in the other answer, or add the command gtk-launch desktop-file-name (where "desktop-file-name" is the name of your .desktop file in ~/.local/share/applications) after installing gtk-launch (more here).

Also, as you posted yourself:

linking the .desktop file to ~/.config/autostart

A question on startup locations: Settings-Applications-Startup list versus ~/.config/autostart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.