Good morning,

Running Loki w/ 4.8.0-34-generic kernel on a 2016 HP Spectre x360 w/ edge drivers loaded (so I can get my wifi to work; Intel 8265 doesn't work in Loki).

Last night I left the OS running, I closed the lid and went to bed. This morning when I opened the lid I was at the login prompt (GUI). Trackpad is dead. So, I toggled by input switching device (this allows me to share keyboard and mouse across multiple devices via USB) so that I could access my external mouse. This worked.

I logged in and everything was fine. Being the curious type, I started to try and figure out how to resolve this lip-closed/open and frozen trackpad. Inevitably I found myself at the console via ctrl-alt+F1. I didn't make any changes, just flipped to console.

Like and idiot instead of just flipping back to GUI login via ctrl-alt+F7, I issued a 'sudo startx' command and got that awesome error. You know the one? That startx is deprecated because it's not safe or whatever.

Anyway, now my system is totally jacked. I cannot login via GUI even after reboot. System presents login, I give password and it acts like it's trying to go to desktop but it never does. Just loops me back to login screen.

cat of Xorg.0.log gives me:

533.404 (II) XINPUT: adding extended input device "ELAN0732:00 04F3:249E" (type: touchscreen, id 10)

Nothing else. And, my wifi card won't come up so I can't even do a re-install on XORG. I've tried raising the device via 'iwconfig' to no avail.

Any ideas where to go from here?

1 Answer 1


It appears that the answer to my problem had to do with .xAuthority being given to root as opposed to my username.

This AskUbuntu post solved it: https://askubuntu.com/questions/223501/ubuntu-gets-stuck-in-a-login-loop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.