0

I'm a complete newbie when it comes to installing and understanding Linux.

I tried to install the NVIDIA drivers with apt, but that only installed some program. Then I downloaded the driver directly from nvidia.com, logged out and stopped lightdm. Then I started the installation file (made it executable with chmod before) and it went through. When I tried to Start lightdm again it didn't do anything. So I rebooted the device and now elementary is stuck on the booting logo. If I press ESC and F1 it reads: error booting elementary

Can someone please explain how to fix that? I have found plenty of posts to this issue but each too technical and each with a different solution, so I'm not sure which to follow.

  • Never install drivers from the nvidia site. Stick to the official repos if you want a stable system. That said, i don't know how to revert what you did. But if you don't mind reinstalling elementary OS you can then follow this elementaryos.stackexchange.com/questions/9605/… to install your nvidia drivers. Or you could just do sudo ubuntu-drivers autoinstall, but this last method may install a driver that's not the latest available. – Maccer Feb 21 '17 at 8:37
  • Ok thank you!!! I will try that. Luckily I had almost nothing on my system :) – NE555 Feb 21 '17 at 22:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.