8

When I turn on my notebook, I put the password and it comes in, the startup icons do not appear, it takes a few minutes, it never happened. How can I solve this problem? 100% updated version elementary OS 0.4 Loki (64-bit)

  • Sometimes after updates a few next startups take a bit longer than usually. – Dysproz Feb 15 '17 at 13:25
7

This is a known bug: https://bugs.launchpad.net/elementaryos/+bug/1596377

This is the workaround: Significant lag loading panel and dock after login (Loki)

mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled

  • Still not working i think it was lightdm error because when i change to gdm3 login is fast.. Sorry my english.. – Dell Feb 24 '17 at 11:10
  • Can anyone explain me how this works? – Sankar Behera Nov 18 '17 at 16:09
  • 1
    basically, the way I understand it, it's trying to autostart a service and it hangs preventing the desktop environment from fully loading. Disabling the service in this way prevents it from being loaded at startup. AT SPI stands for Assistive Technology Service Provider Interface, a framework to integrate accessibility functions in applications. – Sean Patterson Nov 18 '17 at 22:06
0

One of the easy ways to do this is to check that on right clicking the icon a sub menu should appear with the option to run or open the application as administrator. This should take care of those locked folders and files. Currently I am using Elementary OS Loki (64-bit, intel) which is a derivative of Ubuntu 16.04. I hope this should work.

0

I was facing same problem before, but now it is working.

  • Have you placed shortcut of other applications in dock? If so, then can you remove one at a time and check if it is working?

  • Also first try to login with guest account and then go over your account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.