2

I'm trying to install the gnome software centre but its is giving me this error in terminal

sudo apt-get install gnome-software
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-software : Depends: appstream but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have used synaptic package manager. But no broken packages shown.

2

Actually this issue is dealt with here: https://askubuntu.com/questions/879495/update-after-purging-intel-01-org-driver-removed-gnome-software/879516

There is a problem with Ubuntu Xenial packages I believe, and could quite possibly be the cause of your issue. I don't think technically this is an elementary OS issue, but an issue affecting all Ubuntu 16.4 distros.

First run:

apt policy appstream

Now copy a full version number that is not 0.10.16-1 (example 0.10.3-1~ubuntu16.04~ppa2), and then use that in the command replacing with the corresponding version number.

apt install appstream=<version number>

Then install:

apt install gnome-software ubuntu-software

I'm hoping this fix is correct for you and translates to eOS.

And here is the official bug https://bugs.launchpad.net/ubuntu/+source/appstream/+bug/1661460

  • I get the same issue, when i try the install it says its already the newest version. I tried removing/adding appstream again but end up with the same error as the poster – schmoopy Feb 15 '17 at 19:36
  • Actually it worked for me after upgrading elementary – schmoopy Feb 15 '17 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.