0

I have the 378 NVIDIA driver loaded on a new machine, and have found that the tty console (CTRL-ALT-F1) resolution is awful, probably something like 640x480 .

Looking around here and elsewhere, it seems with BIOS installs the answer has been to add some lines to /etc/default/grub and off you go. Since I'm running UEFI, AFAIK grub isn't used.

The CPU is an i7 6700 and the mainboard has its own HDMI port, so in theory I could remove the NVIDIA card and use the Intel driver - I have that running on another machine and it works fine. In this case, however I need to do some OpenGL and accelerated video work, and the in-built Intel GPU isn't my first choice.

Anyone have the answer? The native resolution of the display I'm using is 1920x1080 (1080p) btw.

Thanks!

  • Have you tried following the instructions, as far as I know UEFI still uses a bootloader, which I think is grub - certainly editing the setting (which is 100% present in eOS) is worth a try... Worst case it shouldn't change anything. Hope it works... – SamMorrowDrums Feb 13 '17 at 16:09
  • Thanks for the reply - I did try that, but it didn't change anything. – audioguy Feb 13 '17 at 18:14
  • Just double checking.. did you sudo update-grub after changing the grub config?. Also, did you try with another Nvidia driver? Check what drivers you have available with sudo ubuntu-drivers list and install any of them with sudo apt install nvidia-XXX – Maccer Feb 13 '17 at 21:15
  • 1
    @Maccer, I assume I ran sudo update-grub but since I don't remember now I'll try again. Thanks for the reminder. I also haven't tried any other NVIDIA driver. If necessary I'll look at that or purge the NVIDIA driver and try an AMD card. – audioguy Feb 13 '17 at 22:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.