The key binding for moving an application to the workspace to the left or right does not appear to work. Shift + Super + Left / Right is listed as the appropriate binding in my settings -> keyboard -> shortcuts -> workspaces but it does not appear to work. How can I fix this?

3 Answers 3


I just posted this question in case others had the same problem as me. Here is what I discovered.

The problem stems from SuperShiftLeft and SuperShiftRight already being assigned as shortcuts. Install dconf-editor and navigate to org > gnome > desktop > wm > keybindings. From this you will see that move-to-workspace-left/right is assign both SuperShiftLeft/Right and SuperAltLeft/Right. If you want to utilise the Shift option, then delete the assignments for move-to-monitor-left and move-to-monitor-right as it also uses the same keybinding. I assume these assignments were to move windows between multiple monitors, so if you have more than one monitor set up perhaps delete SuperShiftLeft and SuperShiftRight from the keybindings for move-to-workspace-left and move-to-workspace-right, leaving SuperAltLeft/Right as your navigation options.

  • What if I want to 'flick' an application to the opposite monitor in a dual monitor setup, without changing workspaces? Is there a shortcut to do this?
    – Seth
    Jun 17, 2016 at 15:34
  • There are move-to-monitor-down (and all other directions) keybindings for you to change there. Aug 29, 2017 at 8:29

It seems to be a bug in the keyboard settings plug, use Alt instead of Shift to move an application.

Move to workspace 1: Super+Alt+1
Move to workspace 2: Super+Alt+2
Move to workspace 3: Super+Alt+3
Move to left Super+Alt+Left
Move to right Super+Alt+Right


The SUPER key plus any number key works for me on Luna. However, a second workspace needs to have an application open before a third becomes possible. The SUPER key plus down arrow reveals all open workspaces at the bottom of the screen, allowing one to choose between them with a mouse click if desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.