I've created a custom .desktop file to launch an Android Emulator bash script file. I've successfully gotten the file to launch the emulator but I get two icons in Plank. I've read about this happening with Chrome and needing to add StartupWMClass= but I'm not sure what to put after the =

Here is my .desktop file that launches my bash script shown below that...

[Desktop Entry] Type=Application Encoding=UTF-8 Name=Android Emulator Comment=Android Emulator Exec=/home/elementary/Tools/Emulator/emulator.sh Icon=/home/elementary/Tools/Emulator/emulator_48.png Categories=Utility Terminal=false


cd ~/Android/Sdk/tools ./emulator -avd Emulator -gpu on -qemu -m 2048 -enable-kvm &

1 Answer 1


Found the answer here:


I needed to identify what to place on a StartWMClass and the command xprop WM_CLASS provided that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.