1

Two days ago while I was working with OpenShot video editor that was constantly crashing, my home folder got unmounted. When I tried to access my data there were only two files in my home folder: Access-Your-Private-Data.desktop and a README.txt file. I opened the text file and there was a message:

THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on: "Access Your Private Data"

or

From the command line, run: ecryptfs-mount-private

I ran the ecryptfs-mount-private from the command line where I had to enter my password and my home folder got mounted again. Everything's alright now (I guess) but I still have no idea what happened. I need to know what was going on with my system, what was the cause of the problem. Is there any way to see the log file? Does anyone have any idea what could have caused this and why? Could it be the video editor's fault?

  • The same happens to me sometimes (once every few months). I usually restart to solve the issue. No clue yet why this happens. I find it quite scary, because it looks like someone hacked you, wanting money to decrypt your disk. – Peter Uithoven Dec 14 '17 at 12:06
  • Not sure how/why it happens but this old question mentions a ~/.ecryptfs/auto-umount you could delete to deactivate such behaviour. – Herman van Rink Feb 18 '19 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.