0

I use gigabyte P34G v2. The graphics card is nvidia GTX860m. The OS I use is elementary OS Loki.

$ sudo ubuntu-drivers list ---> check    
$ sudo apt install intel-microcode    
$ sudo apt install nvidia-367

Driver installation is not available. I have nothing to look at nvidia-settings. And I am using Secure Boot.

com@com:~$ nvidia-settings

** Message: PRIME: No offloading required. Abort

** Message: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file
should have been installed along with this driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The
application profiles will continue to work, but values cannot be
prepopulated or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

com@com:~$

com@com:~$ cd /usr/share/nvidia/

com@com:/usr/share/nvidia$ ls -a

.  ..
com@com:/usr/share/nvidia$ 

I went to "/usr/share/nvidia/" and found nothing. How can I use the GTX860m?

have a nice day!


Fundamentally, there was a problem with my motherboard BIOS. I can not shut down after booting to the installation media of any Linux distribution.

Because of this, I spent a lot of time. The solution was to re-update the existing BIOS. Since there is no problem.

The nvidia driver should not use secure boot. I did not read the English message. I have been able to continue to enable Secure Boot. So I installed it but it did not work.

I am currently using it on Ubuntu 16.04.2. Of course before that elementary OS Loki is also good.

0

This will explain how to install nvidia drivers without any problems. I Havent had a problem with this https://www.youtube.com/watch?v=YXgd2w2lr-U&t=95s

  • Thank you for answer. Resolved. First of all, there was a problem with my motherboard BIOS. The problem was that I could not shut down any Linux distributions. I updated the existing BIOS again. Since there is no problem. Driver problem is because I did not read the English message. I should not use Secure Boot. However, I have been able to continue to enable Secure Boot. That was the problem. I am currently using Ubuntu 16.04.2 very well. – SeokHyun Jeong Feb 19 '17 at 13:16
0

Try this:

sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt update sudo apt install nvidia-367 nvidia-settings

For GTX860M you can also try:

sudo apt install nvidia-375 nvidia-settings

  • dude this method is for old Ubuntu distros, 16.04 comes with full support to Nvidia drivers – Egon Stetmann. Jun 20 '17 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.