0

and thanks in advance for any assistance you may be able to provide in this matter. Win8 crashed and I was unable to recover/restore it. So I opted to upgrade to a better OS. I have some previous experience with earlier versions of Linux distros, such as Mint and Slackware (I started using Slack 9, back in the day). However, seeing that much advancement has been made in GUIs, and ease of install (not to mention package management), I thought I'd give elementary OS a try. My wife and I share a laptop, so I had to have the "ease of use factor" for her. And while I do like elementary OS very much, I miss some of the control I had with Slackware. So I added a hard disk, and installed VectorLinux on it. So here is: sda=elementary, sdb=Vector. However, plymouth on elementary doesn't seem to play nice with the addition of Vector. Long-story short: I tinkered with various settings and now I have a blank black screen at boot until the login screen appears for elementary OS. I am able to login and use elementary, but at this point Vector is an unreachable, unusable, colossal waste of money, time and space. At the very least, I would like to get the elementary "e" pulsing again as the OS loads. (As a former Slackware user, my experience has been with LiLo, not grub or plymouth, so please be gentle with your answers.) Any ideas as to how to fix this? Certainly it must be as easy as editing a .conf file somewhere, right?

  • 1
    TL;DR: Fix my grub so that I can boot 2 OS. – Maccer Feb 4 '17 at 11:05
1

I think the problem is that the grub config is messed up. To solve it, do the following:

sudo pantheon-text-editor /etc/default/grub

The file should have a part like this, make sure the options are the same and that everything else on the file is commented out ( # in the beginning of the line).

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=
#GRUB_HIDDEN_TIMEOUT_QUIET=true
#GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Then save the file and run sudo update-grub. Check the output, it should say something about every system you have installed (if you don't see anything regarding Vector Linux, there's another problem..).

Also, I've set grub to always show at boot and wait until you select one option. If you want to boot any option automatically, uncomment GRUB_TIMEOUT and set it to any number greater than 0. E.g: GRUB_TIMEOUT=5

  • Generating grub configuration file ... Found linux image: /boot/vmlinuz-4.4.0-62-generic Found initrd image: /boot/initrd.img-4.4.0-62-generic Found Slackware Linux (Inspired by Slackware Linux) on /dev/sdb2 error: out of memory. error: syntax error. error: Incorrect command. error: syntax error. Syntax error at line 285 Syntax errors are detected in generated GRUB config file. Ensure that there are no errors in /etc/default/grub and /etc/grub.d/* files or please file a bug report with /boot/grub/grub.cfg.new file attached. done – BmaS69 Feb 6 '17 at 1:36
  • Can you paste the contents of /etc/default/grub file in pastebin.com or anything similar and link it here? Also do ls /etc/grub.d/ and tell me the output. Did you modify anything inside that directory? – Maccer Feb 6 '17 at 12:33
1

I'm getting a little closer. There's something about the Vector install on /dev/sdb that grub-mkconfig in elementary does not like. I disabled OS_PROBER, and voila, update-grub generates a new grub.cfg! So, I'm only part-way to solved, but I do now have a grub menu at boot. Plymouth is no longer inserting itself, and I don't have the pulsating "e" logo as elementary loads, but I'm okay with that. As a former Slackware user, I am accustomed to seeing terminal messages scroll. Thanks for your help. If I determine what is causing OS_PROBER to choke on Vector, I'll post an update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.