0

I am trying to find a workaround for the following problem.

I use a Radeon HD 6000 series pci express graphics card with a HDMI output to a tv.

After waking from suspend, no sound.

Opening Pavucontrol tells me the HDMI port is unplugged.

If I have left the sound pane of System Settings open, I can see the HDMI port under 'Play sound through' has disappeared.

Restarting the system or or re-launching System Settings solves the issue.

So: what is the sequence of events when System Settings opens, and can I automate this on-wake to restore HDMI sound automatically?

1

It seems this is a problem introduced by Pulseaudio 8.

Pulseaudio 9 claims to fix the problem (See "Automatic routing improvements", Pulseaudio 9 Release notes).

Upgrading to Pulseaudio 9 doesn't seem possible in Loki or is beyond my techincal level. (EDIT: here is someone trying it in Ubuntu 16.04 and running into unmet dependencies, as I did...).

I even tried removing Pulseaudio entirely and falling back on Gnome-Alsa-Mixer or QASmixer. Neither recognised my HDMI output.

An answer

While it doesn't directly answer my question, this suggestion on AskUbuntu provided me with a quick'n'dirty solution to the problem.

It might only have been a minor annoyance, but now I can switch my TV between games console and HTPC without having to jigger with the HTPC sound settings every time.

I look forward to Juno on the assumption it will use a more recent version of Pulseaudio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.