I added both the Spanish default keyboard layout and the Spanish with dead keys layout from System Settings, but in most applications,when I try to do an accentuated á vowel, in turn it writes: ´a. In some other cases, like in Telegram, the ´ symbol does not appear at all.

I have tried updating, removing all layouts, and what this question suggests on AskUbuntu: https://askubuntu.com/questions/774237/dead-keys-accents-stopped-working-after-upgrading-to-ubuntu-16-04, which is to run ibus-setup and following the instructions, but none worked.

Running elementary OS 0.4 Loki (Ubuntu 16.04 LTS)

Any ideas?


1 Answer 1


I have a mixed bag of input methods using xkb the default and ibus for pali sanskrit keyboard using alt + space. you can try following the instructions at this link here How can I use IBus as the default input method?

Look for the second answer too. You will also need to install another file to get ibus working in gtk.

You also have to install the package ibus-qt4.

If you IBus to automatically start with the system, then go to Settings > Applications > Startup and add ibus-daemon -drx as a custom command.

  • Thanks for your reply. I tried all the steps in the answers of that post, installed ibus-qt4 and made sure the daemo was running. I can now use ibus to toggle through layouts, but dead keys are still not working in any of the two Spanish keyboards I have enabled Feb 2, 2017 at 16:42
  • Make sure the keyboard has those keys enabled. Seems to be something with the layout. There is a complex way to make extra dead keys work. You can google that. "ubuntu custom keyboard layouts" "ubuntu dead keys" I was happy when I got ibus to work because it solved my problem. I was going to go through the custom keyboard thing you might have to do. One last thing you should try is... Some languages have multiple keyboard layouts (like sinhala). Try to verify there is only one (you probably did this already, but just checking). Feb 3, 2017 at 0:13
  • Yes, I already tried that as well. I managed to make the keys work sporadically, with a very dirty solution. I start the system with ibus enabled, then open up fcitx, and the switch the languages on ibus. It somehow makes dead keys work again. Not a permanent solution, but it will have to do for now Feb 3, 2017 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.