1

Installed alacarte menu editor, deleted "Install Elementary OS" icon, now when I try to search for an application, it crashes. I also did an & upgrade, so that may have caused it too perhaps.

Which logs should I paste here for help? I found a bug report here but no fixes yet. Except deleting vim.desktop from ~/.local/share/applications which didn't exist for me. However I did delete ~/usr/share/applications/vim.desktop, which did nothing. Oh and I had like 5 desktop files in that same dir for chrome, delete all them, did nothing.

  • Maybe the problem is that you are using a live cd?? – Maccer Feb 7 '17 at 16:04
  • possibly, but I didn't have these problems before. Some other issues with live cd (well, persistent live usb built using mkusb) I've resolved ie wrong sources.list entries and some other odds & ends - but otherwise it works great! – Craig Skipsey Feb 9 '17 at 6:37
  • I don't think elementary OS is made to use it as a live usb with persistence... Yes, the option is there, but I don't think the devs have put many interest on making it work as a full installation. Personally I'd recommend you to install elementary instead of using a live usb. It takes like 4Gb of space on your disk. I'm sure that with a 10Gb partition you could run it fine and install some apps that you need. This is not the answer to your issue, but maybe it solves that problem as well! – Maccer Feb 9 '17 at 11:53
  • 1
    I am actually facing the exact same situation. Deleted an entry with alacarte and now the wingpanel crashes when I try to search for an app. Please help! – ugachmaaz Jun 11 '17 at 23:58
1

This worked for me:

mv ~/.local/share/applications ~/.local/share/applications.temp

I eventually removed the applications.temp folder.

source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.