I'm trying to mount a sd card on elementary OS 0.4 Loki (64-bit). The drive is recognized in gparted and with sudo fdisk -l but I fail mounting it. Any suggestions?

  • Just mastered to auto mount the card. Had to install exfat-fuse exfat-utils can we put these packages into the core?
    – Oliver
    Jan 28, 2017 at 18:01
  • Does it appear in the devices list in Files? If not, it could be similar to the issue I experienced here. Does it give an error message when you try mounting it? Could you add the output of sudo fdisk -l to your post?
    – Mike Wild
    Jan 28, 2017 at 18:06
  • Yes it appears in pantheon-files and also with the sudo fdisk-l and gparted but the file system is exfat. And when I tried to mount it with sudo mount /dev/mmcblk0 /media following message appear mount: wrong fs type, bad option, bad superblock on /dev/mmcblk0, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so.
    – Oliver
    Jan 28, 2017 at 19:41
  • And the output of the fdisk: Disk /dev/mmcblk0: 59.5 GiB, 63864569856 bytes, 124735488 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0x00000000
    – Oliver
    Jan 28, 2017 at 19:43
  • But after I installed sudo apt-get install exfat-fuse exfat-utils and restarted the system the card is mounted and accessible through pantheon-files
    – Oliver
    Jan 28, 2017 at 19:47

2 Answers 2



sudo apt install exfat-fuse 
sudo apt install exfat-utils

I am just making an answer so that it is solved and people know this. I always have this problem with every distribution.. except I think Mate may have included it.


I usually don't go for the GUI option. But in this case, it was the quickiest.

  1. Open Application menu and type or find Disks app.
  2. Find the SD card and click on the play button to mount its partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.