0

I just installed Elementary Loki How do I get caffeine to work?

It does not show up. If I run it from the term.. I get PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. from gi.repository import GObject, Gtk, GLib

  • What version of elementary are you using? – Mike Wild Jan 28 '17 at 11:19
  • Can you tell us what steps you followed in installing caffeine? And what version you installed. Also, I noticed some tray icons don't show up right in Loki. Maybe it's running in the background? Try to have a look at the running processes. – ThisIsNotAnId Jan 29 '17 at 3:58
  • Here's the launchpad page for caffeine binaries intended for ubuntu xenial (16.04), can you check you have all the listed dependencies installed and up to date? launchpad.net/ubuntu/xenial/+source/caffeine – ThisIsNotAnId Jan 29 '17 at 4:03
  • I checked and the last two were not installed... python-setuptools python3-all I get this error if run from term :~$ caffeine /usr/bin/caffeine:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. from gi.repository import GObject, Gtk, GLib – Bhikkhu Subhuti Jan 29 '17 at 4:57
  • I found the answer.. added ppa answer is below sudo add-apt-repository ppa:caffeine-developers/ppa sudo apt-get update – Bhikkhu Subhuti Jan 29 '17 at 11:28
1

I found the solution. I needed to add the ppa for caffeine

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt upgrade

That seemed to do the trick. Now I have caffeine indicator. Works well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.