0

My NIC is a Realtek RTL8188ee. I'd noticed my browsing speeds on Ubuntu (well, elementary) were slower than on Windows. I did some searching and found this page on GitHub which claims this is primarily due to the limited transmit power for the card which Linux kernels use by default.

My question is, is the driver provided on this page trustworthy? Does anyone know FreedomBen?

Also, is the method he described for installing and replacing the stock driver at least relatively reliable?

Finally, do I need to download an entire new driver to up my wifi speeds or is simply sudo iwconfig <wlan> txpower 33 enough?

Now, I know 33 dBm is the max limit and might be unsafe and illegal, so any pointers here would be greatly appreciated. I am clueless about this.

Many thanks!

migrated from askubuntu.com Jan 25 '17 at 17:22

This question came from our site for Ubuntu users and developers.

1

It seems that Realtek PCI(e) cards do not work well when the firware power save is enabled, it can be disabled with

echo "options rtl8188ee fwlps=N" | sudo tee /etc/modprobe.d/rtl8188ee.conf

Reboot

You do not need a new driver to up your TX power but there is a chance that you will not need to change it after setting the power save to off

  • Hi, thanks for the suggestion. It seems there was no "rtl8188ee.conf" file in "/etc/modprobe.d/" and I just created it by running that command. The file is empty. – ThisIsNotAnId Jan 28 '17 at 19:58
  • The command if copied correctly will create the file and the file will contain options rtl8188ee fwlps=N – Jeremy31 Jan 28 '17 at 20:23
  • I updated the file manually, rebooted. Doesn't seem like there's any improvement. But this maybe because running sudo iwconfig <wlan> showed my power management was off even before creating this file. – ThisIsNotAnId Jan 28 '17 at 21:23
  • Check results for iwlist scan | egrep -i 'ssid|cipher' if below your access point you see TKIP and not CCMP, it could be the wireless encryption used by the router causing the issue. The fwlps setting isn't reflected by iwconfig results and you could edit the /etc/modprobe.d/rtl8188ee.conf to change fwlps to ips so that it is options rtl8188ee ips=N as that will disable all power management by the module and normally isn't needed – Jeremy31 Jan 28 '17 at 22:00
  • Running the first command gives my Group and Pairwise Cipher to be CCMP. I'm hesitant about ips. Would this put the card at risk for overheating or malfunction? I think I like my browsing speed just fine now haha. – ThisIsNotAnId Jan 29 '17 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.