10

when I write my password on terminal for sudo command, it gives me writing feedback even if I didn't modify the sudoers file. How can I fix this? This is my situation:

enter image description here

  • 1
    Are you asking how to disable feedback, or why it was turned on in the first place? – Mike Wild Jan 25 '17 at 12:02
15

This is actually a change that was recently included in a round of updates to Loki. It is briefly mentioned in their new blog post. A package called elementary-default-settings was updated to include a file located at /etc/sudoers.d/pwfeedback, which changes this behavior when entering a password in the terminal.

If you wish to disable the feedback, try this command:

sudo mv /etc/sudoers.d/pwfeedback /etc/sudoers.d/pwfeedback.disabled

This will keep the file around in case you want to re-enable it, which you can do with the following:

sudo mv /etc/sudoers.d/pwfeedback.disabled /etc/sudoers.d/pwfeedback

  • 3
    Thanks! :) I think it's highly irresponsible, to automatically enable password feedback - Why would I want to show anybody how many characters are in my password at all!? – Dysproz Jan 27 '17 at 14:16
  • 1
    Consider that elementary OS is targeted at users switching from macOS and Windows, who probably find the lack of feedback strange. In any case, exposing password length is much less of an issue than using a long password in the first place. – David Berg Jan 29 '17 at 7:42
  • sorry for the late comment: thanks for the answer, works fine! – Mark Ferrer Feb 19 '17 at 13:55
  • Amazing solution, even showing us by any chance we want to revert back. Thank you. – ksugiarto Jan 10 '18 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.