0

I would like to be able to connect to my Loki desktop remotely. I have installed x11vnc but as soon as there is no display connected I can no longer access my desktop from the remote machine.

I am not sure what info is required to help anyone answer my question, but feel free to ask anything of me that may help.

Thanks, DM!

1

Did you try making it run at start up, make sure you've done all of this first to ensure the service is running.

You can also try running sudo service lightdm restart after ensuring that the VNC server is running.

If you are not able to make it work, you can also look at logs:

ls ~/.local/share/xorg/
cat ~/.local/share/xorg/Xorg.1.log (or whatever recent log is called)

Also, what is the output of xrandr when VNC is running? I'm assuming at some point the virtual monitor should appear...

1

For my headless elementary machines, I tend to set up the VNC server via LightDM. It requires the tigervnc server to be installed. You can configure it as follows:

Create a vncpasswd file:

sudo vncpasswd /etc/vncpasswd

Configure /etc/lightdm/lightdm.conf with the following contents:

[VNCServer]
enabled=true
command=Xvnc -rfbauth /etc/vncpasswd
port=5900
listen-address=localhost
width=1024
height=768
depth=24

Then restart the machine or restart lightdm, which will kill your session. VNC should then be listening on the port specified in the config file and you will be presented with the elementary greeter when you connect. Logging into the machine locally will log you out of your VNC session and vice versa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.